Planning BGP security.
The BGPsec project strives to study how to organize and coordinate the global deployment of BGP security protocols.
Securing the global BGP routing system is a multi-decade project.
- 2026 - ASPA becomes standardized
- 2023 - Calgary Internet Exchange deploys world's first ASPA-filtering route servers
- 2020 - Global launch of RPKI Origin Validation (Telia, NTT, LINX, Telstra, HK-IX, GTT, Cogent, Amazon, many others)
- 2019 - RIPE community successfully use RPKI data to clean-up stale IRR data as a continuous process: RIPE-731.
- 2018 - RIPE community successfully closes password 'RPSL' loophole with completion of NWI-5
- 2017 - RFC 8205 published: BGPsec Protocol Specification
- 2017 - RFC 8212 published: EBGP policies 'secure by default'
- 2016 - Peerlock popularized and deployed at various global Carriers
- 2013 - RFC 6811 published: BGP Prefix Origin Validation
- 2012 - RFC 6480 published: An Infrastructure to Support Secure Internet Routing
- 2006 - IETF Secure Inter-Domain Routing (SIDR) working group started
- 2006 - Department of Homeland Security publishes a road map for Secure Protocols for the Routing Infrastructure Initiative.
- 2004 - RFC 3779 published: X.509 Extensions for IP Addresses and AS Identifiers